4.2. Installing Prerequisites

To program AVRs in Linux, you will need the free avr-gcc compiler, avr-libc, AVRDUDE, and other associated tools. Ubuntu users can get the required software by running:

sudo apt-get install gcc-avr avr-libc avrdude

Users of other Linux distributions should install all relevant AVR-related packages available in their distribution’s package manager.